HobbyCNC fórum
  v0.9.2 alpha

Fórum betekintő Fórum címe: http://forum.hobbycnc.hu



LinuxCNC a gyakorlatban

xxxx


Időrend:
Oldal 1 / 89 Ugrás ide:
1  2   3   4   5     Következő ►  Utolsó ►|

Fórum főoldal  |  A lap aljára

Messer | 296    2017-09-26 01:07:57 [4415]

Használja Valaki a EMC2-t S-görbés gyorsítással? Nem használom ezt a programot. Mach3-hoz kerestem megoldást (egyelőle nem sok sikerrel) , közben ezt találtam. s-curve.py


zozo | 2707    2017-09-24 19:27:48 [4414]

Pár éve szórakoztam a szimulációs részében egy 4 csuklópontos scara robottal, próbáltam átírogatni a config fájlokat és figyelni a változást. A képernyőre grafikusan kirakja a robotot és látod a mozgásokat. Valamit rajzoltattam vele, de torzított rajta. Aztán eltettem későbbre. A később azóta is tart, de jó lenne ha valaki kitaposná az ösvényt Első lépésként, barátkozásnak talán érdemes a minta configot kipróbálni, akár egy pendrive-ra telepített linuxcnc-n.

Előzmény: svejk, 2017-09-24 16:55:16 [4413]


svejk | 24706    2017-09-24 16:55:16 [4413]

Foglalkozott közületek valaki robotkarral? Van itt egy 5 szabadságfokú gyári, de ugye természetesen vezérlő nélkül. A maghajtásokat még megoldanám de a szoftver? Emlékeim szerint még a hagyományos Descartes féle maró/eszterga elrendezésnél is sokat kellett a HALL file-okkal dolgozni, gondolom a robot része főleg nincs kitaposva.


zoller | 3    2017-09-16 12:51:14 [4412]

2.8.0 ??? Olyan is van már??? Egyébként g55-el indult is el, mint legutóbb hagytam. Van némi anomália a fejemben a G61 G61.1 és G64-el kapcsolatban. A g61 esetén a g64 paraméterei érvényesek, vagy a három kód "üti" egymást?

Előzmény: KoLa, 2017-09-11 21:02:00 [4411]


KoLa | 5968    2017-09-11 21:02:00 [4411]

Most hogy írod... Nálam 2.8.0 verzió!

Előzmény: zoller, 2017-09-11 20:17:27 [4409]

KoLa | 5968    2017-09-11 20:31:36 [4410]

Szia János! Megnéztem! az ini fájlban az emc.var a paraméterek helye. Megnyitottam ezt a fájlt, és itt is két oszlopban van mint ahogy írtad! Átküldöm.

Előzmény: bjam28, 2017-09-11 09:43:21 [4408]


zoller | 3    2017-09-11 20:17:27 [4409]

Hali! Én is csináltam valami hasonlót nemrég, reggel bekapcsoltam, g55 benne van, ahogy legutóbb hagytam. 2.7.0 "gyári" állapotban, szintén eszterga.


bjam28 | 642    2017-09-11 09:43:21 [4408]

Szia Lajos! A G54/55/56... koordinátákat megjegyzi a program. Induláskor betölti, kilépéskor kiírja egy fájlba. A INI fájl [RS274NGC] szekciójában kell lennie egy PARAMETER_FILE = bejegyzésnek a megfelelő fájlra hivatkozva. Fontos még a fájl formátuma: két oszlop, az első egy sorszám (egész) a második az érték (1234.567 formában). Ennek a paraméter fájlnak a /home/kola/linuxcnc/configs/tekonfigod/ mappában kell lennie. A konkrét sorok a G55-re vonatkozóan: 5241-5250, azaz ezekkel az értékkel kezdődő sorok tartalmazzák a G55 koordinátákat. Küldd el az INI és a paraméter fájlt, hogy többet lássak a dologból.

Előzmény: KoLa, 2017-09-10 20:08:39 [4407]


KoLa | 5968    2017-09-10 20:08:39 [4407]

Eszterga módban próbáltam darabolásra használni a g54 g55 g56 adta lehetőséget,két szerszámot bemértem, mindhárom koordináta rendszerre,mivel még vannak műveletek leszúrás előtt, tökéletesen működött egész nap, de másnap reggelre csak a g54 maradt a helyén a másik kettő elszállt! Mit csinálok rosszul?nem kellett volna ezeknek is megmaradni?


remrendes | 1376    2017-08-20 16:14:49 [4406]

Targytalan.

Előzmény: remrendes, 2017-08-20 11:11:31 [4405]


remrendes | 1376    2017-08-20 11:11:31 [4405]

A gmoccapy honnan veszi a stepconf-ot? Hiaba jogolok, egyik motor sem mozdul, pedig a DRO szerint igen es az axis gui is tokeletesen mukodik.


horcsab | 290    2017-08-17 16:40:34 [4404]

FF0, FF1 adj értéket. Nagy sebességnél lép be.

Előzmény: smalla, 2017-08-17 15:31:33 [4402]


smalla | 891    2017-08-17 16:05:54 [4403]

Juteszembe, az X tengelynél már visszakapcsoltam a tahót (feedback)

Előzmény: smalla, 2017-08-17 15:31:33 [4402]


smalla | 891    2017-08-17 15:31:33 [4402]

a P értéke szinte mindegy (látszólag), de 10 alatt biztos kevés, 10 től kezd el normálisan mozogni, de aztán magától nem rezonál be akkor sem ha P 10000. csak úgy ha kimozdítom a holtpontról. az at_pid modul autótuning módban egyébként egészen elképesztő számokat generál, és persze azokkal rögtön kiakad a gép, de valami olyasmiket, hogy P 60000-80000, I 180000-2500000(!), D 17-63 és nincs két egyforma. Az X axishoz beállított paraméterekkel, 0,1-es elmozdulással szép a görbe, jó a megállás, de használhatatlanul lassú. OUTPUT_SCALE = 277.77 OUTPUT_MIN_LIMIT = -238.09 OUTPUT_MAX_LIMIT = 238.09 FEEDBACK_SCALE = 238.09 FEEDBACK_MIN_LIMIT = -238.09 FEEDBACK_MAX_LIMIT = 238.09 Az Z axishoz tartozó beállításokkal egész jól mozog a gép, akár folyamatosan is anélkül, hogy kiakadna, de a pontossága csapnivaló. És ennél még lehetne jóval gyorsabb is. OUTPUT_SCALE = -2857.0 OUTPUT_MIN_LIMIT = -2857.0 OUTPUT_MAX_LIMIT = 2857.0 FEEDBACK_SCALE = -3333.0 FEEDBACK_MIN_LIMIT = -3333.0 FEEDBACK_MAX_LIMIT = 3333.0 próbáltam az X tengelyhez beállított paraméterek egész többszöröseivel kb 6000-es számokig, de ott nem igazán lehet 1mm nél nagyobb elmozdulást kinyerni belőle. Most jut eszembe, hogy lehet a homing is bezavar, lehet azért nem megy gyorsabban, mert hiszen még nem volt hazaküldve és addig le van korlátozva. Na ezt este kipróbálom.

Előzmény: D.Laci, 2017-08-17 15:11:33 [4401]


D.Laci | 3406    2017-08-17 15:11:33 [4401]

Nagyoknak találom azokat az értékeket. Nekem LPT porton valami ilyesmi a jó beállítás: P = 4 I = 1 D = 0.01 BIAS = 0.5 FF0 = 0 FF1 = 0 FF2 = 0 DEADBAND= 0.00015

Előzmény: smalla, 2017-08-17 13:32:01 [4400]

smalla | 891    2017-08-17 13:32:01 [4400]

itt van a teljes konfig: https://github.com/smalla/configs/tree/master/XYZAC320 többé kevésbé naprakész, habár a tegnap esti működésemet nem szinkronizáltam még rá.

Előzmény: D.Laci, 2017-08-17 10:15:39 [4399]


D.Laci | 3406    2017-08-17 10:15:39 [4399]

Az INI fájlt rakd fel vagy küld el nekem had nézek bele.

Előzmény: smalla, 2017-08-17 09:50:33 [4398]


smalla | 891    2017-08-17 09:50:33 [4398]

Tegnap kicsit játszogattam vele. Ha a beállításokat leveszem (output scale, min-max), akkor nagyon szép pid görbéket látok és elég pontosan áll be a gép az adott helyre, ha csak 0,1mm mozgást kérek tőle. De veszett lassú, ha kicsit nagyobb távot kellene megtenni. Gyors mozgásokat végezni lehetetlen, ki is akad. Mekkora lehet kb a gyorsulása egy ekkora gépnek? Mert azt (is) feltételezem, hogy ez végletesen magasra van állítva a szoftverben, és a gép nem tudja követni. Az X tengellyel játszadozok: motor ~ 4,5Kw, 23Nm 2000RPM, 10mm golyós orsó emelkedés, kb 200-250kg tömeget kell mozgatni üresen. Inerciát ne kérdezzetek, lövésem sincs. Ha magasabbra állítom az output scale értékeket, akkor megindul a motor, de lehetetlen (?!?) jól pozícióba állítani.

Előzmény: smalla, 2017-08-16 16:11:58 [4397]


smalla | 891    2017-08-16 16:11:58 [4397]

Fanuc System 6M, ez a leírás fedi, csak nem a H-s vezérlőt kell nézni, hanem az M-est. most úgy próbálkozok vele, hogy tacho jel (TGLS jumper helyén) nélkül megy, mert azzal együtt végképp sztochasztikusan működött. Az elképzelés az volt, hogy ha így sikerül nagyjából beállítani, akkor visszaengedélyezem a tacho jelet. este le tudom fényképezni a pontos típust.

Előzmény: horcsab, 2017-08-16 15:29:18 [4396]


horcsab | 290    2017-08-16 15:29:18 [4396]

Amit Pál írt, tacho jel az fontos a hajtás végfoknak. Anélkül is ezt a jelenséget csinálhatja, vagy ha nem megfelelő a jelszint. A végfokot nem lehet átállítani tacho jel nélküli üzemre? Küldj egy pontos típust a végfokról, utánanézek, hátha találok róla valamit.

Előzmény: smalla, 2017-08-16 10:12:22 [4395]


smalla | 891    2017-08-16 10:12:22 [4395]

Persze, már vagy tízszer, hátha elsiklottam valami felett.

Előzmény: bjam28, 2017-08-15 15:22:54 [4394]


bjam28 | 642    2017-08-15 15:22:54 [4394]

Szia! Lehet hogy már nézted John Thornton oldalát, bár most éppen nem elérhető csak Google cache-ből: Servo Tuning Tutorial Itt a hibahatár is 20mm az egy helyett...

Előzmény: smalla, 2017-08-15 10:07:30 [4388]


§ Pál § | 7266
(Kitiltva 2017-11-02 21:00:00-ig!)
   2017-08-15 14:47:05 [4393]

Nem olyan egyszerű ennél a dolognál a probléma. A vezérlő egy ősöreg Fanuc rendszer volt. A DC szervó vezérlő analóg , de a motorokon nincs tachogenerátor eredetileg sem. A Fanuc vezérlő egység az encoder jelekből generált egy tacho feszültséget. Elméletileg ez is meg van oldva, de a próba enélkül volt kivitelezve. Így a szervó vezérlő belső P tagja is belebarmolhatott a beállításba. Tehát ez így sok sebből vérzik.

Előzmény: horcsab, 2017-08-15 12:51:50 [4391]


smalla | 891    2017-08-15 13:35:03 [4392]

Köszönöm a tippet. Sajnos nem, olyankor azonnal a világ végére szalad(na), de itt nem ez a helyzet.

Előzmény: horcsab, 2017-08-15 12:51:50 [4391]


horcsab | 290    2017-08-15 12:51:50 [4391]

Enkóder nincs fordítva bekötve? Csak tipp!

Előzmény: smalla, 2017-08-15 10:07:30 [4388]


smalla | 891    2017-08-15 11:21:43 [4390]

Igen, 3 tengely már mozog az 5-ből, csak még nem az elvárásaimnak megfelelően.

Előzmény: § Pál § , 2017-08-15 10:55:13 [4389]


§ Pál § | 7266
(Kitiltva 2017-11-02 21:00:00-ig!)
   2017-08-15 10:55:13 [4389]

Kezd összeállni a masina ? Mikor ott voltam akkor még a trafó sem volt a hajtásokhoz. Azóta sikerült szerezni ?

Előzmény: smalla, 2017-08-15 10:07:30 [4388]


smalla | 891    2017-08-15 10:07:30 [4388]

Kellene nekem némi segítség LinuxCNC + mesa 7i77 + Fanuc DC szervók PID tuningjához. Van valami anomália a rendszerben, amitől nem úgy működik a PID ahogy az a nagy könyvben meg van írva. És mivel ez lenne az első ilyen amit beállítok, nem igazán találom a hiba okát. Például: 1) azt írják, hogy növeljem a P-t, amíg önálló oszcillációban nem kezd, majd vegyem vissza. Az én rendszerem álló helyzetből, magától nem kezd el oszcillálni, mindegy meddig növelem a P értékét. 2) ha kimozdítom a holtpontból egy vezérlő utasítással (+0.1mm) akkor már egész kicsi P értékre is egyre nagyobb oszcillációba kezd, míg le nem kapcsol a túl nagy kitérés miatt. Nem találok stabil rezonancia frekvenciát, ami kellene a Ziegler Nichols féle beállításhoz. 3) ha sikerül próbálgatással beállítani PID értékeket, melyek kvázi működnek, azok csak az egyik irányba működnek. Ha a másik irányba indítom meg a szerkezetet, akkor vagy jóval nagyobb lesz a hiba, vagy egyenesen ki is akad a hibahatár (1mm) túllépése miatt. 4) Stabil gyorsjáratot nem sikerült beállítanom, ott szinte mindig nagyon nagy a hiba, ezért a max sebesség kb 150mm/perc ami több, mint lassú. Egyszóval béna vagyok hozzá, kellene a segítség. Lassan már hetekben mérhető a rá fordított időm, és szerintem ez tengelyenként max 1 óra kéne legyen. Köszönöm


Szasza43 | 94    2017-08-11 20:01:39 [4387]

Köszönöm.

Előzmény: horcsab, 2017-08-11 17:58:13 [4386]


horcsab | 290    2017-08-11 17:58:13 [4386]

Ha tudok, segítek, ha időm is engedi.

Előzmény: Szasza43, 2017-08-11 14:09:02 [4385]

Szasza43 | 94    2017-08-11 14:09:02 [4385]

Szia, Köszönöm, hogy segíteni akartál, de ujra telepítettem és így már jó. Esetleg ha valamibe megakadok kérhet tőled segítséget? Üdvözlettel: Szabolcs

Előzmény: horcsab, 2017-08-11 07:28:53 [4384]


horcsab | 290    2017-08-11 07:28:53 [4384]

küld el a konfig fileokat. Abból tudok segíteni.

Előzmény: Szasza43, 2017-08-10 17:20:30 [4383]


Szasza43 | 94    2017-08-10 17:20:30 [4383]

Sziasztok, Segítséget szeretnék kérni linuxcnchez. Feltelepítettem 2.7 verziót. Mindent beállítottam a configba, és próbáltam működött is. Aztán valamit elállítottam, de sajnos nem tudom mit, mert sok mindent próbálgattam. Most nem akar menni sem joggal sem programmal. A configba ha próbálom a tengelyeket működnek. A szervo motorok tartásba vannak. A segítséget előre is köszönöm.


smalla | 891    2017-08-01 11:27:21 [4382]

Adjak DNS-t ?

Előzmény: bjam28, 2017-08-01 09:21:19 [4380]


lari | 983    2017-08-01 09:34:44 [4381]

Rendben,köszönjük

Előzmény: bjam28, 2017-08-01 09:21:19 [4380]


bjam28 | 642    2017-08-01 09:21:19 [4380]

Szia! Tudok róla, a szerver maga működik csak a DNS szolgáltató gondolt egyet.... Rövidesen (szeptembertől) újra elérhető lesz és ismét lesznek gyakoribb friss hírek, információk. Addig megértést kérek, de itt vagy magánban szívesen segítek. Üdv: János

Előzmény: lari, 2017-08-01 09:16:09 [4379]


lari | 983    2017-08-01 09:16:09 [4379]

Szia János! A linuxcnc.hu nem működik. Tudsz róla?

Előzmény: bjam28, 2017-08-01 09:11:44 [4378]


bjam28 | 642    2017-08-01 09:11:44 [4378]

Szia! A hasonló esetekről azt írják a fórumokon, hogy 1) a PCI kártya csatlakozó felülete koszos vagy a kártya hely ahová behelyezed a kártyát elszennyeződött. Tisztítsd meg a kártyá érintkezőit és próbáld bele másik kártya helybe. 2) A firmware (bit file) nem elérhető. Jó helyre tetted? Egy INI és HAL fájl részlet még segíthetne. Jöhet magánban is.

Előzmény: csike, 2017-07-31 20:40:17 [4377]


csike | 152    2017-07-31 20:40:17 [4377]

Szeretnék segítséget kérni egy Mesa 5i23 kártya beüzemelésébe. Nem beszélek Angolul. Egyedi BIT fáj Előre köszönöm a segítséget.


smalla | 891    2017-03-31 14:10:01 [4376]

Ejnyje no, kevés a tábla csoki? vagy túl nehéz a feladat ?

Előzmény: smalla, 2017-03-25 21:29:11 [4367]


vjanos | 4439    2017-03-27 10:55:50 [4375]

Kemény vagy

Előzmény: smalla, 2017-03-27 10:48:31 [4374]


smalla | 891    2017-03-27 10:48:31 [4374]

Tegnap este még játszogattam vele, az eredmény, hogy minden gomb használható, a tengelyválasztó és a felbontásválasztó is működik. Ami nem megy még az a 2 gomb együttes kezelése, valamint továbbra sem tudom, hogy az ominózus 2 oszlopban milyen adatok vannak... És persze a kijelzőre visszaírás az egyáltalán nem megy még...

Előzmény: smalla, 2017-03-26 14:16:56 [4370]


KoLa | 5968    2017-03-26 16:51:41 [4373]

Kontakt hibája volt az optó csatinak és gondoltam lehúzom róla teljesen, így vettem észre ezt a dolgot az index jellel kapcsolatban. Azután odaforrasztottam a vezetékeket. A Linuxcnc nem is annyira csicsa. Te csacsi!

Előzmény: Robsy, 2017-03-26 14:28:11 [4371]


lazi | 1309    2017-03-26 14:35:15 [4372]

Semlegesben valóban várom a véleményedet...

Előzmény: Robsy, 2017-03-26 14:28:11 [4371]


Robsy | 453    2017-03-26 14:28:11 [4371]

"csak ebben az esetben nem talál vissza a menetárokba!" Akkkooo mééééé csinálja? Nem az lenne a legfontosabb, hogy ne iduljon el index szinkron jel hiányában? Ha ez tényleg így van, újabb csicsavilág jelenséget nyugtázhatunk, azaz nagy hühó a semmiért.

Előzmény: KoLa, 2017-03-25 21:55:41 [4368]

smalla | 891    2017-03-26 14:16:56 [4370]

Igen, ezt olvastam, sajnos ez a day of month xor mintha itt nem működne, valami más az algoritmus sztem. Ezt volna jó kitalálni

Előzmény: horcsab, 2017-03-26 10:31:26 [4369]


horcsab | 290    2017-03-26 10:31:26 [4369]

Ezt gondolom megtaláltad. Link Igaz, nem pont az a típus, de talán kiindulásnak nem rossz.

Előzmény: smalla, 2017-03-25 21:29:11 [4367]


KoLa | 5968    2017-03-25 21:55:41 [4368]

Nem kell az index jel ahhoz hogy elinduljon a menetvágás!kipróbáltam! kiszámolja szerintem az A phase configból is, és indul akkor is ha nem jön az index jel, csak ebben az esetben nem talál vissza a menetárokba! Nincs ebből probléma, csak a működési elvet cikizem! Ha van korrekt index jel akkor téveszthetetlenül működik! Az A-B phase használata is nagy különbséget eredményez ha pl csak A phaze van a configban!de ezt, Te biztos tudod csak úgy megjegyzem.

Előzmény: D.Laci, 2017-03-24 06:04:07 [4365]


smalla | 891    2017-03-25 21:29:11 [4367]

Éljen, az első 3 gomb működik. Kéne némi help, mert nem jövök rá magamtól: ki kellene találni, hogy a második és nyolcadik oszlopban mi alapján változnak a számok, felajánlok egy tábla csokit a megfejtőnek. 04 40 01 00 0E 13 00 7F 04 57 00 00 0E 13 00 04 04 0E 01 00 0E 13 00 0F 04 DE 00 00 0E 13 00 0C 04 21 01 00 0E 13 00 01 04 CC 00 00 0E 13 00 0C 04 C1 01 00 0E 13 00 01 04 18 00 00 0E 13 00 08 04 E4 01 00 0E 13 00 03 04 A9 00 00 0E 13 00 08 04 BF 01 00 0E 13 00 0D 04 71 00 00 0E 13 00 00 04 DC 01 00 0E 13 00 0B 04 A9 00 00 0E 13 00 08 04 D5 01 00 0E 13 00 05 04 04 00 00 0E 13 00 04 04 65 01 00 0E 13 00 05 04 0C 00 00 0E 13 00 0C 04 D4 01 00 0E 13 00 03 04 E4 00 00 0E 13 00 04 04 77 01 00 0E 13 00 05 04 D7 00 00 0E 13 00 04 04 8C 01 00 0E 13 00 0B 04 4A 00 00 0E 13 00 08 04 CB 01 00 0E 13 00 09 04 06 00 00 0E 13 00 04 04 45 01 00 0E 13 00 05 04 FD 00 00 0E 13 00 0C 04 3C 01 00 0E 13 00 0B 04 0A 00 00 0E 13 00 08 Csak az 1-es gombot nyomogattam, ami a 3. oszlopban látható változás. De a 2. és 8. oszlopok számomra ismeretlen konstellációban változnak minden alkalommal. Erre kéne rájönni. Köszi


GG | 56    2017-03-24 08:24:13 [4366]

Pedig de. Irok neked.

Előzmény: smalla, 2017-03-23 23:50:35 [4364]


Fórum főoldal  |  A lap tetejére

Időrend:
Oldal 1 / 89 Ugrás ide:
1  2   3   4   5     Következő ►  Utolsó ►|